Category Archives: Technical

Vivek Bhat

December 9, 2014

As this site is in migration phase from one host to another, there may be some issues in accessing some pages, some misses here and there. Due to this had to disable friendly URL’s as of now!

Mis-Aligned text in Konsole

I have started using Monaco as my coding font. I also use this font in Konsole, KDE Terminal emulator. I don’t know since when, but iy has been a while that font in Konsole appears mis-aligned. Monaco is a fixed width font, so this problem is somewhat weird. As usual, a google search took me to this post and made these lines at the end of my ~/.fonts.conf, before And this has really solved my problem for now.

“Un-Coupling” KMix and Amarok Volumes

I don’t know since when, but for a while now I am seeing this behavior in my KDE 4.14 desktop that when I increase or decrease volume using KMix, volume in othet KDE applications also increases or decreasing correspondingly. Basically it means, there are no separate controls for KMix and other KDE applications. Tried to search on web, and came across this KDE bug where it explains this is called “flat volumes”. Some people may like this feature, but not me right now. And, Here is how to disable flat volumes. Simply add: in /etc/pulse/daemon.conf to disable this system wide or in ~/.config/pulse/daemon.conf to disable for the user.

Enable mod_rewrite in apache2

If wordpress permlinks are not working for you, the first thing you should check is if mod_rewrite module is enabled! Learned this the hard way.
How to check:
Run phpinfo() and in Loaded Modules sections the mod_rewrite should be present. Just do a CTRL-F after running phpinfo() and check if it finds mod_rewrite

Loaded Modules core mod_access_compat mod_so http_core prefork mod_unixd mod_systemd mod_actions mod_alias mod_auth_basic mod_authn_file mod_authz_host mod_authz_groupfile mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_expires mod_include mod_log_config mod_mime mod_negotiation mod_setenvif mod_ssl mod_userdir mod_php5 mod_reqtimeout mod_authn_core mod_authz_core

So, if it is not there, edit your /etc/sysconfig/apache2 and add “rewrite” to APACHE_MODULES
Restart your apache2 server, if it starts without any errors, run phpinfo. mod_rewrite should be there now!

RMAN archivelog deletion policy

Today I faced issues while starting my Oracle database. While startup/opening the database I was getting the error: I checked my “Alert log” which was at In there was this line So the issue was my recovery size was full! Oracle gives you the below options for this problem First I need to delete the files to recover the space: After that change RMAN retention policy to avoid this problem in future: